Archivos Mensuales: abril 2011

España se prepara para dar el salto al protocolo IPv6

La IPv4 tiene 4.295 millones de direcciones; la IPv6 tiene 340 sextillones.

El Consejo de Ministros ha aprobado el plan para la incorporación del nuevo protocolo de Internet, el IPv6, en España, que coexistirá “durante unos años” con el antiguo IPv4.

Debido al agotamiento de las direcciones de la versión anterior del protocolo, el Ministerio de Industria ha impulsado un plan cuyo objetivo es difundir información didáctica sobre el IPv6 y dinamizar los cambios tecnológicos que resulten necesarios para su incorporación efectiva.

Entre otras medidas, el Gobierno ha creado una web informativa sobre el nuevo protocolo, a la que se sumarán jornadas teórico-prácticas sobre sus aspectos técnicos y ayudas del Plan Avanza para proyectos relacionados con él.

Internet se quedaba sin direcciones

Las direcciones IP (Internet Protocol) constituyen el sistema de identificación que permite que diferentes dispositivos conectados a Internet puedan comunicarse entre sí. Desempeñan en Internet un papel análogo al número telefónico en el servicio de telefonía tradicional, permitiendo el intercambio de información entre dos o más puntos de la red.

Sin embargo, en Internet no hay una planificación de los recursos de direccionamiento por parte de las Administraciones Públicas: el responsable de la asignación de direcciones es la corporación sin ánimo de lucro ICANN (Internet Corporation for Assigned Names and Numbers).

Desde 1981 se emplea el denominado protocolo IP versión 4 (IPv4), que ofrece alrededor de 4.295 millones de direcciones de Internet a nivel global. En su momento se consideró “suficiente” para cubrir todas las necesidades de futuro.

No obstante, en febrero de este año la ICANN asignó en su totalidad el repositorio global de direccionamiento IPv4 y, previsiblemente, a lo largo del año se producirá también la asignación total de las direcciones IPv4 disponibles en Europa.

Ante la rápida extensión de Internet a escala global, en el año 1998 se desarrolló la versión IPv6, que permite la asignación de 340 sextillones de direcciones únicas de Internet, una cantidad prácticamente ilimitada, pasando la longitud de la dirección IP de 32 a 128 bits de longitud.

Además, el protocolo IPv6 introduce nuevas mejoras en Internet, entre ellas más seguridad y simplicidad de procesamiento en la red, según asegura Industria.

Fuente: www.elmundo.es

Anuncios

Control editor de texto open-source: TinyMCE + NetImageBrowser

En ocasiones un cliente puede desear encargarse él mismo del mantenimiento de la página web que se le ha diseñado sin tener que retocar directamente el código fuente.

Para ello se suelen programar aplicaciones web desde las cuales se puede actualizar una página web,  utilizando un recurso bastante común, el uso de controles llamados WYSIWYG (What You See Is What You Get).

Un control WYSIWYG es un editor de texto que permite modificar el contenido de una página web asociada, colocando los elementos tal y como queremos que se visualicen (como si escribiéramos un documento de MSWord).

Existen varios controles editores de texto conocidos, algunos de ellos gratuitos, los cuales dejan bastante que desear en algunos aspectos. Es el caso del control FreeTextBox para ASP.NET, que entre otros problemas, escribía gran cantidad de código basura cuando se hacía copy/paste desde un documento de Word, ya que, al hacer la conversión interna de los estilos de Word a HTML en el editor, incluía muchas etiquetas innecesarias. Esto puede parecer una tontería, que se solucionaría convirtiendo el contenido a texto plano e introduciendo nuestros propios estilos manualmente, pero implica una pérdida de tiempo que el cliente prefiere no asumir.

Estuve buscando otros editores gratuitos que solucionaran este problema y que añadieran otras funcionalidades, pero ninguno satisfacía por sí solo todas las necesidades. El que más me convenció fue TinyMCE, un control basado en html y javascript, lo que permite su integración de forma muy sencilla en cualquier plataforma, incluido ASP.NET.

Podemos probar cómo funciona desde la página oficial. Aquí.

Como he dicho antes, la integración es muy sencilla. Vamos a ver cómo.

–          En primer lugar abrimos nuestro Visual Studio (en este ejemplo uso 2008), hacemos clic en File>Website y elegimos ASP.NET Website si queremos empezar un nuevo sitio web.

–          Nos descargamos la última versión disponible del tinyMCE desde aquí.

–          Descomprimimos el fichero y copiamos la carpeta TinyMCE en nuestra solución de Visual Studio, como se muestra abajo.

–          Ahora arrastramos un control de cuadro de texto ASP.Net en nuestra página aspx y establecemos la propiedad TextMode a Multiline.

–          Para utilizar las características de TinyMCE con el cuadro de texto Multiline, necesitamos incluir el fichero Tiny_MCE.js, que se encuentra en la carpeta tinymce/jscripts/tiny_mce/ del paquete, en nuestra página web.

<script type="text/javascript"
src="tinymce/jscripts/tiny_mce/tiny_mce.js"></script>

–          A continuación tenemos que llamar al API javascript de tinyMCE para convertir el cuadro de texto Multiline a una instancia del editor, tal y como se muestra abajo.

<head runat="server">
<script type="text/javascript"
src="tinymce/jscripts/tiny_mce/tiny_mce.js"></script>
<script type="text/javascript" language="javascript">
   tinyMCE.init({
       mode: "textareas"
   });
</script>
  <title></title>
</head>

–          ¡Y ya está! Ejecutamos la página y podemos ver nuestro control. Por defecto, el editor TinyMCE incluirá una barra de herramientas de configuración simple con algunas herramientas básicas. Así:

–          El código final nos quedaría así:

<head runat="server">
<script type="text/javascript"
src="tinymce/jscripts/tiny_mce/tiny_mce.js"></script>
<script type="text/javascript" language="javascript">
    tinyMCE.init({
        mode: "textareas"
    });
</script>
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
    <asp:TextBox ID="TextBox1" TextMode="MultiLine"
runat="server"></asp:TextBox>   
    </div>
    </form>
</body>
</html>

Dentro del código javascript podemos incluir todas las herramientas que incluye la versión gratuita, en la columna que deseamos que se sitúe. Sustituyamos en el código anterior, la parte comprendida entre las líneas <script type=”text/javascript” src=”tinymce/jscripts/tiny_mce/tiny_mce.js”></script>  y </script> (ambas incluidas) por el siguiente código:

<script type="text/javascript"
src="tinymce/jscripts/tiny_mce/tiny_mce.js"></script>
<script type="text/javascript" language="javascript">
    tinyMCE.init({
        // General options
        mode: "textareas",
        theme: "advanced",
        plugins: "safari,pagebreak,style,layer,table,save,advhr,
advimage,advlink,emotions,iespell,inlinepopups,insertdatetime,
preview,media,searchreplace,print,contextmenu,
 paste,directionality,fullscreen,noneditable,visualchars,nonbreaking,
 xhtmlxtras,template,wordcount",
        // Theme options
        theme_advanced_buttons1: "save,newdocument,|,bold,italic,
underline,strikethrough,|,justifyleft,justifycenter,justifyright,
justifyfull,styleselect,formatselect,fontselect,fontsizeselect",
        theme_advanced_buttons2: "cut,copy,paste,pastetext,pasteword,
|,search,replace,|,bullist,numlist,|,outdent,indent,blockquote,|,
undo,redo,|,link,unlink,anchor,image,cleanup,help,code,|,insertdate,
inserttime,preview,|,forecolor,backcolor",
        theme_advanced_buttons3:  "tablecontrols,|,hr,removeformat,
visualaid,|,sub,sup,|,charmap,emotions,iespell,media,advhr,|,print,
|,ltr,rtl,|,fullscreen",
        theme_advanced_buttons4: "insertlayer,moveforward,movebackward,
absolute,|,styleprops,|,cite,abbr,acronym,del,ins,attribs,|,visualchars,
nonbreaking,template,pagebreak",
        theme_advanced_toolbar_location: "top",
        theme_advanced_toolbar_align: "left",
        theme_advanced_statusbar_location: "bottom",
        theme_advanced_resizing: true,
        // Drop lists for link/image/media/template dialogs
        template_external_list_url : "lists/template_list.js",
        external_link_list_url : "lists/link_list.js",
        external_image_list_url : "lists/image_list.js",
        media_external_list_url : "lists/media_list.js"
        }
    });
</script>

Al ejecutar de nuevo la página podemos ver el resultado:

Sin embargo, esta versión tiene un importante déficit respecto de la que hemos visto en el ejemplo de la página oficial, y es que no permite incluir imágenes descargadas desde el propio pc o servidor. Para eso hay que pagar.

Aunque también podemos programar nosotros mismos el plugin…o buscar en internet por si alguien ya lo ha hecho, como es el caso :D.

El plugin que encontré, en concreto, se llama netImageBrowser y podemos descargarlo desde aquí. El autor tiene como nombre de usuario, Ilyax.

Incluir este plugin en nuestro proyecto es tan sencillo como copiar la carpeta netImageBrowser que hemos descargado en el directorio tinyMCE/plugins/, y añadir la nueva herramienta en el código javascript. Por ejemplo en la tercera columna, quedando así:

        theme_advanced_buttons3: "tablecontrols,|,hr,removeformat,
visualaid,|,sub,sup,|,charmap,emotions,iespell,media,advhr,|,print,
|,ltr,rtl,|,fullscreen",
        theme_advanced_buttons4: "insertlayer,moveforward,
movebackward,absolute,|,styleprops,|,cite,abbr,acronym,del,
ins,attribs,|,visualchars,nonbreaking,template,pagebreak
,netImageBrowser",

Con este nuevo control podemos subir imágenes desde nuestro pc a nuestro servidor, cuya dirección debemos especificar en el fichero up.aspx, modificando en las siguientes líneas:

private string path =
        HttpContext.Current.Server.MapPath("../../../images");
private string imgPath = "../../../images";

los paths en negrita por los paths de nuestro servidor. Una vez hemos subido los ficheros ya pueden ser incluidos en nuestro editor de texto. En este enlace podemos ver un ejemplo de cómo funciona este control. Es el icono con forma de carpeta que aparece en la primera columna del editor.

Ya he incluido este control en alguna aplicación, en concreto la de la página del Observatorio de la Universidad Cardenal Herrera – CEU, cuya página principal (y casi todas las demás también) pueden ser modificadas por el usuario a través del control situado en la aplicación.

A continuación vemos una captura de pantalla del editor utilizado en la aplicación para actualizar la página principal:

Y el resultado final se ve enlazando con la página web. (El contenido puede ser distinto del de la foto de arriba si el usuario ha decidido modificarlo desde el editor para actualizar su web…¡Ese es el objetivo! ).

Eso es todo. Un saludo.

Jornada sobre empleo y talento en el sector TIC

Organizada por CISCO en Colaboración con sus principales Partners.

¿Reconoces una buena oportunidad?

¿Deseas potenciar tu carrera en el sector TIC?

¿Te interesa la tecnología CISCO?

Miércoles, 11 de Mayo de 2011, de 9:30h a 18:00h
en Cisco Madrid
Avda. de la Vega 15 Edif. 4
28100 Alcobendas (Madrid)

El objetivo de este evento es dar a conocer las diferentes vías de Desarrollo Profesional en el entorno tecnológico a través de Cisco y sus principales Partners, facilitando el acceso directo a las oportunidades de empleo tanto a futuros talentos como a profesionales en activo.

Tendrás oportunidad de:

  • Participar en foros de discusión relacionados con el sector de TIC.
  • Conocer y acceder a los principales partners de Cisco donde desarrollar tu actividad profesional.
  • Conocer el entorno tecnológico de Cisco.

Accederán con preferencia los candidatos con certificaciones Cisco (CCNA 3 en adelante).

Acércate y descubre nuevas oportunidades en tu futuro profesional.

Para asistir a la jornada será imprescindible realizar el registro:                                                                           http://www.partnertalentevents.com/candidates/madrid

Adjunta tu Currículum Vitae, de este modo facilitarás la planificación de reuniones individuales y en grupo con las empresas asistentes.

Asimismo, queremos recordarte que puedes adjuntar tu candidatura en el Talent Portal, espacio donde las empresas publican sus ofertas de trabajo:                                                                                                  http://www.partnertalentportal.com/europe/login.asp

Esperando contar con tu presencia en La Jornada sobre Empleo y Talento Tecnológico, recibe un cordial saludo,

Cisco & Partners de Cisco.

Fuente: Cisco Networking Academy <news_netacad@cisconaemeaspanish.imakenews.net>  

Aprobada la utilización de la banda ancha 4G en Europa.

Ya se le ha hecho un sitio a la conexión 4G en Europa y la Comisión del continente ha adoptado ya las normas técnicas necesarias para abrir las bandas de 900 y 1800 MHz, con el fin que no sufra interferencia con la tecnología GSM y la 3G.

Con esto se intentará que un mayor número de ciudadanos tengan acceso a banda ancha  y al mismo tiempo, garantizar que todas las comunicaciones funcionen a la perfección, desarrollando así todas las posibilidades que tienen.

Hay que recordar que la implantación de esta tecnología fuera de Japón no se esperaba hasta el periodo de tiempo que va desde el año 2015 al 2020.

Esta tecnología esta basada totalmente en el protocolo IP, formando un sistema de sistemas y una red de redes, que se logra alcanzar gracias a la convergencia entre las redes de cables e inalámbricas y a la fusión de varios protocolos, no siendo un único estándar.

La 4G podrá ser usada por modems inalámbricos y dispositivos móviles varios. La principal diferencia con las generaciones anteriores será la capacidad para ofrecer velocidades de acceso mayores de 100 Mbps en movimiento y 1 Gbps en reposo, manteniendo una calidad de servicio (QoS) nodo a nodo de alta seguridad que permitirá ofrecer servicios en cualquier momento y lugar, a un coste mínimo.

Características técnicas.

El concepto de 4G, incluye técnicas de avanzado rendimiento radio como MIMO y OFDM. Dos de los términos que definen la evolución de 3G, siguiendo la estandarización del 3GPP, serán LTE (‘Long Term Evolution’) para el acceso radio, y SAE (‘System Architecture Evolution’) para la parte núcleo de la red. Los requisitos ITU y estándares 4G indican las siguientes características:

  • Para el acceso radio abandona el acceso tipo CDMA característico de UMTS.
  • Uso de SDR (Software Defined Radios) para optimizar el acceso radio.
  • La red completa prevista es todo IP.
  • Las tasas de pico máximas previstas son de 100 Mbps en enlace descendente y 50 Mbps en enlace ascendente (con un ancho de banda en ambos sentidos de 20Mhz).

Fuentes:

http://www.adslayuda.com/

http://es.wikipedia.org/

Cómo optimizar el SEO de las páginas de Facebook

Facebook

Si tu compañía ha establecido una buena estrategia de posicionamiento en buscadores (SEO) para tu página de empresa y ha establecido un plan de social media agresivo, está en el camino correcto, puesto que estos dos ejes vertebran el éxito de muchos negocios en Internet. Sin embargo, ¿te has planteado una estrategia cruzada que conecte estas dos áreas?

Si tu compañía es como la mayoría, es posible que su página de marca en Facebook no aparezca entre los 20 primeros resultados en buscadores, aún cuando la página Web sí lo hace. Aparentemente, según un estudio de BrightEdge, esto les ocurre a más del 70% de las grandes empresas que han iniciado estrategias de este tipo.

Aunque la presencia en redes sociales no sea una vía inmediata para atraer volumen de negocio, la imagen y el compromiso que pueden llegar a percibir los consumidores es inigualable. Si consigues que la gente encuentre tu página y haga clic en “Me gusta” estás creando una vía para ofrecerles tus novedades y logrando un flujo de comunicación con tus consumidores que tu página web no puede ofrecer. Las ventajas son notables también en otros casos como el de Flickr.

Afortunadamente, optimizar una página de Facebook para buscadores es relativamente sencillo y no requiere todos los procesos a los que te obliga el SEO en el caso de un sitio web.

Cuida tu nombre de usuario

Facebook ofrece a las marcas la oportunidad para configurar una URL (o un nombre de usuario) al que hay que prestarle atención no solo para fomentar la viralidad y el marketing de boca a boca, sino que también juega un papel crucial en el SEO.

Si todavía no has hecho este paso –necesitas al menos 25 fans para poder hacerlo-, no lo dudes. En general, tienes que intentar que sea lo más posible y lo más cercano al nombre original de la marca. Tienes que saber que Facebook no permite guiones u otros símbolos como la barra baja en estas URL, por lo que los trucos típicos para las palabras clave en los dominios no siempre sirven. Recuerda que el nombre de usuario no se puede cambiar en este caso, así que elige con cuidado.

Piensa en las búsquedas internas

Puede resultar obvio, pero el nombre que utilices en tu página de marca en Facebook es realmente importante. Nuevamente, tener en cuenta el nombre original de la marca es vital ya que, además de los buscadores, ayudará a la gente a encontrarlo dentro de la red social.

Aquí tienes la oportunidad de introducir algunas palabras clave, no demasiadas, asi que selecciona una cadena sencilla que incluya los términos más importantes de tu estrategia SEO. Tranquilo habrá otras oportunidades para posicionar estos y otros keywords.

No te dejes un campo de información vacio

Facebook te ofrece la posibilidad de rellenar tres campos para describir de forma amplia tu compañía: “Acerca de”, “Descripción” e  “Información General”. Rellénalos todos.

El más breve de los tres es “Acerca de”, donde tienes espacio para una o dos frases que describan tu negocio. Los otros dos campos te ofrecen más espacio, pero debes ser conciso. Aquí es importante que en la redacción de estas reseñas incluyas las palabras clave que te interesan.

Hay otros campos, que también conviene rellenar, ya que aumentan las posibilidades de que la gente encuentre tu marca con el buscador interno de la página.

Enlázalo desde tu página oficial

No te olvides que la esencia del algoritmo del Pagerank de Google siguen siendo los hipervínculos. Enlaza tu página de Facebook desde tu Web y desde otros sitios donde tengas oportunidad, es importante que mantengan alguna relación con el sector de negocio.

Sin embargo, hay que recordar que si enlazas tus actualizaciones de Facebook desde tu página, no estarás ayudando a tu estrategia SEO puesto que estos links incluyen el atributo “nofollow”. Sin embargo, pueden ser una manera para dar dinamismo e intercambiar tráfico entre ambos sitios.

Fuente: http://www.readwriteweb.es

La batalla de la búsqueda social

seo

La búsqueda social vuelve a ser “trending topic” con el lanzamiento de Google +1 y pone de relevancia que el futuro va más allá del ‘link graph’ (entendido como la relación de enlaces entre webs) y pasa por la inteligencia colectiva.

Generalmente cuando hablamos de ‘social search’ (y así está expresado en la versión inglés de la Wikipedia) nos referimos a un “tipo de búsqueda que toma en cuenta el ‘social graph’ de una persona […] dando más visibilidad a los contenidos creados por usuarios dentro de dicho ‘social graph’”.

Ahora bien, es probable que esta definición sea parcial o empiece a estar obsoleta, ya que deja de lado el que parece será el factor fundamental en el futuro de las búsquedas, estamos hablando de la inteligencia colectiva, es decir, la inteligencia que surge de la colaboración de muchos y que no debemos confundir con el “social graph” (que no es más que el conjunto de nuestras relaciones). Indudablemente lo que comentan mis contactos sociales, en especial en los temas que compartimos, me resultan más interesantes que los de gente que no conozco, pero ¿qué pasaría si incorporamos de una manera ordenada el resto de opiniones de la gente para determinar la calidad de ciertos contenidos? ¿Acaso no son los contenidos de Wikipedia de gran calidad y útiles, y no tengo ningún tipo de relación con dichos editores?

Cuando la web tenía básicamente un uso informacional, es decir, puro acceso a la información y sin apenas conversación, esa genial idea de Google “un enlace a una web es un voto de calidad… y no todos los votos valen lo mismo” y que es la base de su algoritmo, ofrecía resultados espectaculares y revolucionó el mundo de las búsquedas, haciendo pasar a un gigante como Yahoo! en poco más de un año a ser un eterno segundón.

La web social como nueva revolución del SEO

Pero la web de hoy en día es completamente diferente a la web de finales de los 90, donde Google y su famoso PageRank fueron creados, y por mucho que Google haya trabajado por mejorar su fórmula, refinando la calidad de los enlaces y añadiendo muchos filtrados de credibilidad, la realidad es que la web social se presenta como la gran alternativa al modelo del ‘link graph’.

A día de hoy la calidad de los resultados de Google ha descendido de manera estrepitosa, los enlaces son manipulados y toda una industria ha nacido en torno a ello (el SEO). La compra de enlaces es habitual y hasta el New York Times escribe sobre ello, con la repercusión que ello tiene y la incomodidad que ello debe generar en el seno de la compañía. A eso debemos sumar la cantidad de contenido generado cada día y la exigencia de información a tiempo real, a la que Google difícilmente puede responder ante el reto tecnológico de indexar cantidades ingentes de contenidos creado cada minuto.

Frente a ello están naciendo nuevos gigantes, uno de ellos especialmente preocupante para la compañía de Palo Alto, Facebook, que además está financiada en parte por Microsoft. Si Google era el paradigma de la web informacional, Facebook es el baluarte de la web conversacional, si Google es la web de los datos, Facebook es la web de las personas y tal vez, las personas seamos mejores para determinar la calidad de los resultados de búsqueda que una máquina.

Así pues, Facebook acumula diariamente millones de sitios web que se comparten y hacen me gusta dentro de su plataforma, cerrada y que por tanto no es accesible a Google (pero sí al aliado de Facebook; Bing), mientras Google sigue mirando enlaces cada vez más corrompidos, Facebook tiene acceso real a lo que gusta a los usuarios y qué duda cabe que esa información aplicada a los rankings de búsqueda puede suponer una revolución como la que Google trajo en su día al tener en cuenta los enlaces para calcular las posiciones en sus páginas.

Google + 1 no deja de ser un intento de Google de apoderarse de parte de esa inteligencia colectiva, inteligencia valiosísima para calcular el interés de ciertos sitios web, para detectar webs de baja calidad y al final para ofrecer mejores resultados. ¿Será capaz Google de extraer suficiente información de este sistema? ¿Llega Google demasiado tarde y el cambio de ciclo ya ha empezado? El futuro de las búsquedas sociales no solo se presenta apasionante, sino también necesario para mejorar para la calidad de los resultados, habrá que seguir atentos a nuestras pantallas.

Fuente: http://www.readwriteweb.es

Cómo implementar redes WAN seguras y convergentes. Simulación de una VPN con IPsec en GNS3.

1. INTRODUCCIÓN.

IPsec es un marco de estándares abiertos desarrollados por el Internet Engineering Task Force (IETF), que proporciona seguridad para la transmisión de información sensible a través de redes sin protección, como es el caso de Internet.

IPsec actúa en la capa de red, lo que hace que sea más flexible frente a otros protocolos que actúan a partir de la capa de transporte (modelo OSI), como SSL, TLS o SSH. Así, proporciona protección y autenticación de los paquetes IP entre los dispositivos IPsec participantes (“pares”), por ejemplo dos routers de Cisco.

En la figura siguiente se ofrece una visión simplificada de cómo funciona IPsec en un router
Cisco. Dos routers establecen un túnel IPsec virtual entre sí utilizando algoritmos y parámetros comunes. El tráfico de color rojo es el tráfico que fluye a través del router, que sirve para ir a Internet y no a través del túnel VPN. El verde es el tráfico que pretende ir de un sitio a otro a través del túnel IPsec VPN.

¿Pero por qué utilizar IPsec para crear redes privadas virtuales?

Porque debemos asumir que los nodos externos pueden ser maliciosos e IPsec proporciona una solución de seguridad más robusta que los servicios propiertarios de Cisco y está basada en estándares.

¿Y entonces por qué utilizar routers Cisco?

Porque, al fin y al cabo, Cisco es el líder mundial en el suministro de hardware y soluciones de software de redes LAN y WAN. La sede de la empresa Cisco se encuentra en San Francisco y las sucursales y distribuidores autorizados de Cisco en la actualidad existen en la mayoría de los países en el mundo por lo tanto los dispositivos de hardware de Cisco se utilizan en todas las regiones del mundo. Así pues, creo que puede ser interesante mostrar un ejemplo de su funcionamiento.

2. HERRAMIENTAS DE USO.

Para esta práctica, actualmente no puedo contar con el hardware necesario para construir una maqueta en la que poder mostrar el funcionamiento de una VPN con IPsec, por lo que he decidido utilizar un simulador gráfico de red, el GNS3. 

GNS3 es un simulador de distribución libre que permite diseñar topologías de red complejas y poner en marcha simulaciones sobre los routers. Está estrechamente relacionado con Dynamips, un emulador de IOS que permite a los usuarios ejecutar imágenes de las IOS de los routers de Cisco Systems. En conjunto, se trata de una buena herramienta complementaria a los verdaderos laboratorios para administradores de redes Cisco y en especial para estudiantes. Lo podéis descargar desde aquí.

La IOS escogida para este ejemplo es la del Cisco router 7200, que aunque comienza a estar anticuado, sabemos que soporta las funciones de configuración para la implementación de una VPN con IPsec. He subido la imagen que he utilizado yo a Megaupload. Podéis descargarla desde este enlace.

Una vez cargada la imagen de la IOS y seleccionado el espacio de trabajo, podemos comenzar a diseñar nuestra topología.

3. ESCENARIO. 

La maqueta está formada por tres routers c7200. Hay que arrastrar cada uno de los dispositivos al espacio de trabajo y configurar sus interfaces. Así pues, seleccionamos el router añadido con el botón derecho del ratón y hacemos click en la pestaña Slots. Nuestros routers dispondrán, por ejemplo, de un slot con una interfaz Fast-Ethernet y de otro con 8 interfaces Serie.

La topología final será la siguiente, los routers R1 y R3 estarán conectados a R2, que es el router externo que se conecta a Internet. R1 se conecta mediante su interfaz Fast-Ethernet. El uso del switch en la vida real será necesario o no según si usamos conectores RJ45 directo (para dispositivos desiguales) o cruzado (para dispositivos igualitarios). R3 se conectará a R2 mediante una interfaz serie.

Para conectar los routers mediante las interfaces simplemente se usa el icono con forma de conector que se observa en la imagen superior y se hace click en uno de los nodos que queremos conectar, arrastrándolo hasta el otro nodo.

Cuando ya esté todo conectado, pulsamos el play para activar el funcionamiento de nuestra maqueta.

Para comenzar a configurar los routers, ya sólo hace falta pulsar el icono de consola, y se abrirán automáticamente tres ventanas que emularán las consolas de los routers. Ya podemos empezar a configurar, utilizando el Cisco IOS command-line interface.

Los objetivos son los siguientes:

  • Configurar las interfaces de direccionamiento de los routers así como un protolo de routing, por ejemplo, EIGRP.
  • Crear una VPN IPsec entre los nodos R1 y R3, para evitar que R2 pueda ver los paquetes enviados.
  • Verificar el funcionamiento de IPsec.

A partir de ahora veréis un seguimiento paso a paso.

4. CONFIGURACIÓN DE LAS INTERFACES.

En primer lugar configuraremos las interfaces de loopback y las interfaces serie, asignando las direcciones IP a cada una y aplicando el comando ‘no shutdown’ a todos las conexiones físicas para dejarlas abiertas. El comando ‘clock rate’ es necesario para sincronizar las interfaces Serie.

Aplicaremos un clock rate de 64000 bits por segundo en el conector DCE.

Imaginaremos que hemos contratado la subred 192.168.12.0/24, que usaremos para las interfaces Fast-Ethernet y la subred 192.168.23.0/24 para las interfaces serie. La interfaz de loopback de R1 será la 172.16.1.1/24 y la de R2, la 172.16.3.1/24.

En todos los routers, habilitamos el modo configuración global y le ponemos un nombre para evitar confusiones a la hora de configurar. Los mensajes que contienen un asterisco son los mensajes de confirmación que nos aparecen por consola a medida que escribimos las órdenes.

Router>enable
Router#configure terminal
*Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#

Ahora configuraremos las interfaces de cada uno de los routers.

R1(config)#interface loopback0
*Jun 8 10:30:51.335: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0,
changed state to up
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#interface fastethernet0/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
*Jun 8 10:36:39.063: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to
up
*Jun 8 10:36:39.063: %ENTITY_ALARM-6-INFO: CLEAR INFO Fa0/0 Physical Port
Administrative State Down
*Jun 8 10:36:40.063: %LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/0, changed state to up
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
*Jun 8 10:47:02.647: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to
down
*Jun 8 10:47:02.647: %ENTITY_ALARM-6-INFO: CLEAR INFO Fa0/0 Physical Port
Administrative State Down
*Jun 8 10:47:02.647: %ENTITY_ALARM-6-INFO: ASSERT CRITICAL Fa0/0 Physical Port
Link Down
R2(config-if)#interface serial1/0
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#clockrate 64000
R2(config-if)#no shutdown
*Jun 8 10:48:39.323: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
*Jun 8 10:48:39.323: %ENTITY_ALARM-6-INFO: CLEAR INFO Se1/0 Physical Port
Administrative State Down
*Jun 8 10:48:40.327: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0,
changed state to up
R3(config)#interface loopback0
*Jun 8 10:51:27.167: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0,
changed state to
R3(config-if)#ip address 172.16.3.1 255.255.255.0
R3(config-if)#interface serial1/0
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown
*Jun 8 10:52:51.315: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
*Jun 8 10:52:51.315: %ENTITY_ALARM-6-INFO: CLEAR INFO Se1/0 Physical Port
Administrative State Down
*Jun 8 10:52:52.319: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0,
changed state to up

Para comprobar que tenemos conectividad entre las subredes locales usamos el comando ping.

R1#ping 192.168.12.2
*Type escape sequence to abort.
*Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
!!!!!
*Success rate is 100 percent (5/5), round-trip min/avg/max = 164/217/300 ms
R3#ping 192.168.23.2
*Type escape sequence to abort.
*Sending 5, 100-byte ICMP Echos to 192.168.23.2, timeout is 2 seconds:
!!!!!
*Success rate is 100 percent (5/5), round-trip min/avg/max = 140/192/220 ms

5. CONFIGURAR EIGRP

Con la intención de mantener conectividad entre redes remotas, configuramos EIGRP (un protocolo de routing propietario de Cisco) para poder enrutar entre todas las redes del diagrama. Añadiremos todas las subredes conectadas a cada router al Sistema Autónomo 1 y deshabilitaremos la sumarización de redes automática para que todas las subredes sean visibles desde todos los puntos.

R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 172.16.0.0
R1(config-router)#network 192.168.12.0
*Jun 8 11:34:40.299: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.12.2
(FastEthernet0/0) is up: new adjacency
R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.12.0
*Jun 8 11:34:40.003: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.12.1
(FastEthernet0/0)
R2(config-router)# network 192.168.23.0
*Jun 8 11:34:46.963: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.23.3
(Serial1/0) is up: new adjacency
R3(config)#router eigrp 1
R3(config-router)#no auto-summary
R3(config-router)#network 172.16.0.0
R3(config-router)#network 192.168.23.0
*Jun 8 11:34:46.851: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.23.2
(Serial1/0) is up: new adjacency

Ahora ya deberíamos tener conectividad total por IP. Lo probaremos con el siguiente script TCL en R1.

R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#172.16.1.1
+>(tcl)#192.168.12.1
+>(tcl)#192.168.12.2
+>(tcl)#192.168.23.2
+>(tcl)#172.16.3.1
+>(tcl)#192.168.23.3
+>(tcl)#} { ping $address }

6. CREAR POLÍTICAS IKE

Para implementar una VPN con IPsec, en primer lugar hay que implementar los parámetros “Internet Key Exchange” (IKE), utilizados para validar las políticas entre pares.

IKE es un protocolo que define el método de intercambio de claves sobre IP en una primera fase de negociación segura. De esta forma, los pares intercambian las políticas IPsec para la autenticación y la encriptación del tráfico de datos.

La política IKE controla la autenticación, el algoritmo de encriptación y el método de intercambio de claves usado por las propuestas IKE, siendo enviados y recibidos por los extremos IPsec. La política IPsec se usa para encriptar tráfico de datos enviado a través de un túnel VPN.

Para poder empezar a trabajar, hay que habilitar IKE. En algunas IOS está habilitado por defecto, pero por si acaso ejecutaremos el comando correspondiente.

R1(config)#crypto isakmp enable

Para permitir la negociación, en primer lugar hay que crear una política ISAKMP (Internet Security Association and Key Management Protocol) y configurar la asociación entre los pares que participan en la política ISAKMP. Ésta política define la autenticación, los algoritmos de encriptación y la función hash utilizada para enviar tráfico de control entre los dos nodos de la VPN.

Para iniciar las política ISAKMP introducimos el siguiente comando en modo configuración global.

R1(config)#crypto isakmp policy 10

Si a continuación introducimos el parámetro ‘?’ podemos ver todos los parámetros IKE disponibles. Al conjunto de parámetros que se utilizan para definir los requerimientos de seguridad de una comunicación en una dirección particular (entrante o saliente), se le llama “Asociación de Seguridad” (SA).

La elección de un algoritmo de encriptación controlará la confidencialidad del canal de control entre los dos nodos. El algoritmo hash controla la integridad de los datos. El tipo de autenticación se asegura de que, en efecto, el paquete fue enviado y firmado por el par remoto.

El grupo Diffie-Hellman se usa para crear una clave secreta compartida por los pares que nunca haya sido enviada a través de la red.

Vamos a configurar una autenticación de claves pre-compartidas. Utilizaremos encryptación AES 256 (es decir una clave de 256 bits y un tamaño de bloque de 16 bytes) y SHA como algoritmo hash, además de Diffie-Hellman grupo 5 (1536 bits) para esta política IKE.

Le daremos a esta Asociación de Seguridad un tiempo de vida de 3600 segundos (una hora). Se trata del tiempo máximo en el que una política de seguridad se utiliza sin necesidad de negociarla de nuevo. Obviamente, esta configuración hay que aplicarla a los dos nodos en los que crearemos la VPN.

R1(config)#crypto isakmp policy 10
R1(config-isakmp)#authentication pre-share
R1(config-isakmp)#encryption aes 256
R1(config-isakmp)#hash sha
R1(config-isakmp)#group 5
R1(config-isakmp)#lifetime 3600
R3(config)#crypto isakmp policy 10
R3(config-isakmp)#authentication pre-share
R3(config-isakmp)#encryption aes 256
R3(config-isakmp)#hash sha
R3(config-isakmp)#group 5
R3(config-isakmp)#lifetime 3600

Aunque sólo necesitamos configurar una política aquí, podemos configurar mútliples políticas IKE. Los diferentes números de prioridad están relacionados con la seguridad. Cuanto menor sea el número, más segura es la política. Los routers comprobarán y verificarán qué políticas de seguridad con compatibles con sus pares, comenzando con la política de menor número.

Podemos verificar nuestra política IKE con el comando show crypto isakmp policy.

7. CONFIGURAR CLAVES PRECONPARTIDAS.

Una vez elegido nuestro método de autenticación, tenemos que configurar una clave en cada router que se corresponda con el otro nodo de la VPN. Las claves utilizadas deben coincidir para que la autenticación sea satisfactoria y para que la relación IKE entre pares se complete.

Por simplicidad, utilizaremos la clave “sssi”. Obviamente, para cualquier otro caso se debería utilizar una clave más compleja. Usaremos el comando crypto isakmp key sssi address junto con las direcciones IP de las interfaces físicas de los nodos del extremo opuesto.

R1(config)#crypto isakmp key sssi address 192.168.23.3
R3(config)#crypto isakmp key sssi address 192.168.12.1

8. CONFIGURAR EL IPSEC TRANSFORM SET Y LOS LIFETIMES.

El IPsec transform set es otro parámetro de configuración cifrada que negocian los routers para formar Asociaciones de Seguridad. De la misma forma que las políticas ISAKMP, también pueden existir múltiples transform sets en un router. Los routers compararán sus transform sets con el par remoto hasta encontrar uno que coincida.

Crearemos un transform set IPsec usando la sintaxis “crypto ipsec transform set”. Utilizaremos el caracter ‘?’ para descubrir los parámetros disponibles.

IKE está formado por una cabecera de autenticación “Authentication Header” (AH) o por una cabecera de autenticación más encriptación que se conoce como “Encapsulating Security Payload” (ESP). Una Asociación de Seguridad puede ser AH o ESP, pero no ambas. IPsec ofrece dos modos de operación según utilice AH o ESP para proteger los datos sobre IP. Se conocen como “modo de transporte” (si usamos AH) o “modo túnel” (si usamos ESP). En esta ocasión vamos a decantarnos por ESP.

Así pues, ejecutamos el comando en ambos routers.

R1(config)#crypto ipsec transform-set 50 esp-aes 256 esp-sha-hmac
R3(config)#crypto ipsec transform-set 50 esp-aes 256 esp-sha-hmac

Podemos especificar nuestro tiempo de seguridad asociado un vez creado el transform-set. A continuación cambiaremos, en R1 y R3, nuestro límite de tiempo a 30 minutos.

R1(config)#crypto ipsec security-association lifetime seconds 1800
R3(config)#crypto ipsec security-association lifetime seconds 1800

9. DEFINIR EL TRÁFICO QUE NOS INTERESA.

Ahora que todas las opciones de encriptación están claras, definiremos listas de acceso extendidas para decirle al router qué tráfico debe encriptar. En este caso, un paquete al que se le permite, mediante una lista de acceso usada para definir tráfico IPsec, será encriptado si la sesión IPsec ha sido configurada correctamente. Sin embargo, un paquete denegado por alguna de estas listas de acceso no se tirará, sino que será enviado sin encriptar.

Como en todas las listas de acceso, existe un “deny” implícito al final, que en este caso implica que la acción por defecto es no encriptar tráfico. Si no hay una asociación de seguridad correctamente configurada, entonces tampoco se encriptará el tráfico, sino que será enviado sin encriptar.

En este escenario, el tráfico que vamos a encriptar es tráfico procedente de la dirección de loopback de R1 hasta la dirección de loopback de R3, o viceversa. Las listas de acceso se usan en las interfaces de salida de los nodos terminales de la VPN, por lo que debemos configurarlas acorde a esto. La configuración de la lista de acceso de R1 debe ser exactamente el espejo de la de R3 para que funcione correctamente.

R1(config)#access-list 101 permit ip 172.16.1.0 0.0.0.255 172.16.3.0 0.0.0.255
R3(config)#access-list 101 permit ip 172.16.3.0 0.0.0.255 172.16.1.0 0.0.0.255

Como se puede observar, las máscaras en las listas de acceso se escriben como máscaras invertidas, siendo en realidad redes /24 como hemos indicado al comienzo de la memoria.

10- CREAR Y APLICAR CRYPTO MAPS

Ahora que hemos creado estos pequeños módulos de configuración, podemos llevarlos todos a un crypto map. Un crypto map es una asignación que asocia el tráfico que coincide con una lista de acceso (como la definida anteriormente) a un par de nodos y a diversas políticas IKE y opciones de IPsec. Estos mapas de cifrado pueden tener múltiples sentencias, por lo que podríamos obtener tráfico que coincide con una cierta lista de acceso siendo encriptado y enviado a otro par IPsec, y por otro lado obtener otro tráfico que coincide con una lista de acceso diferente siendo encriptada hacia otro nodo diferente.

Una vez que un mapa de cifrado haya sido creado, puede ser aplicado a una o más interfaces, pero siempre debería aplicarse a las interfaces enfrentadas con la interfaz de su par IPsec.

Para crear un mapa de cifrado, usaremos el comando “crypto map” en modo configuración global, al que añadiremos un nombre y un número de secuencia, e introduciremos la configuración deseada asociada a ese número de secuencia. Muchas sentencias de los mapas de cifrado pueden pertenecer al mismo crypto map, y en ese caso serían evaluados en orden numérido ascendente. También introduciremos el tipo de cifrado. En cuanto a esto último, si usamos el tipo “ipsec-isakmp” significa que se usará IKE para establecer asociaciones de seguridad con IPsec, al contrario de lo que ocurriría en caso de seleccionar el tipo “ipsecmanual”.

Vamos a llamar al crypto map “MAPA1” y utilizaremos el número de secuencia 10. Cuando entremos en el modo de configuración de mapas de cifrado en R1 nos aparecerá una advertencia, indicando que el peer debe estar completamente configurado antes de que el mapa de cifrado sea considerado válido y pueda ser aplicado activamente.

R1(config)#crypto map MAPA1 10 ipsec-isakmp

Ahora usaremos el comando “match address” junto al número de la lista de acceso creada para especificar qué lista de acceso definirá el tráfico a encriptar.

R1(config-crypto-map)#match address 101

El comando “set” nos ofrece muchas posibilidades para trabajar con un mapa de cifrado. Vamos a utilizar el carácter de ayuda ‘?’ para conocerlas.

Algunos de estos comandos son imprescindibles, como “set ip”, “set peer” o “set hostname”. Los aplicaremos a la interfaz del nodo del otro extremo de la VPN. Además seleccionaremos el número del transform set definido anteriormente.

También seleccionaremos el comando “set pfs claves” (perfect forwarding secrecy type) cuya clave está directamente relacionada con el tipo de módulo Diffie-Hellman seleccionado. Desde este modo de configuración también podemos modificar el tiempo de vida de la Asociación de Seguridad. La configuración nos ha quedado así:

R1(config-crypto-map)#set peer 192.168.23.3
R1(config-crypto-map)#set pfs group5
R1(config-crypto-map)#set transform-set 50
R1(config-crypto-map)#set security-association lifetime seconds 900
R3(config)#crypto map MAPA1 10 ipsec-isakmp
% NOTE: This new crypto map will remain disabled until a peer and a valid access list
have been configured.
R3(config-crypto-map)#match address 101
R3(config-crypto-map)#set peer 192.168.12.1
R3(config-crypto-map)#set pfs group5
R3(config-crypto-map)#set transform-set 50
R3(config-crypto-map)#set security-association lifetime seconds 900

Ahora que los mapas de cifrado han sido creados, el último paso en el proceso de creación VPN’s nodo a nodo es aplicar los mapas a las interfaces. Esto lo conseguimos entrando en modo configuración de interfaz e introduciendo el comando “crypto map nombre”. Es necesario comprender que las asociaciones de seguridad no se establecerán hasta que el mapa de cifrado sea activado al reconocer tráfico que le interesa.

No crearemos dicho tráfico aún, porque tendremos que permitir algunos comandos de depuración en próximos pasos.

De momento, el router generará una notificación indicando que se ha activado el cifrado en dichas interfaces.

R1(config)#interface fastEthernet 0/0
R1(config-if)#crypto map MAPA1
*Jun 8 21:07:24.167: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is ON
R3(config)#interface serial 1/0
R3(config-if)#crypto map MAPA1
*Jun 8 21:08:38.295: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is ON

11. VERIFICAR CONFIGURACIÓN

En el paso 6 usamos el comando “show crypto isakmp policy” para mostrar las políticas ISAKMP configuradas en el router. De forma similar, el comando “show crypto ipsec transform set”
muestra por pantalla las políticas IPsec configuradas en los transform sets.

A continuación usaremos el comando “show crypto map” para mostrar los mapas de cifrado que
se han aplicado al router.

Esta información no cambiará aunque haya tráfico “interesante” cruzando a través de la conexión.

12. VERIFICAR OPERACIÓN IPSEC.

Si usamos el comando “show crypto isakmp sa”, éste nos revelará que no existen asociaciones de seguridad IKE todavía. Esta información de salida se verá modificada en cuanto se comience a enviar tráfico “interesante”.

Si ahora usamos el comando “show crypto ipsec sa”, este comando nos mostrará las asociaciones de seguridad en desuso entre R1 y R3. Podemos fijarnos en la ausencia, tanto de paquetes enviados a través como de asociaciones de seguridad. Esto último se muestra hacia la parte inferior de la salida en ambos routers.

13. INTERPRETAR EVENTOS DE DEPURACION.

En términos de la comunicación real entre los puntos extremos de la VPN, ISAKMP establece normas estrictas en cuanto a cómo puede ser una asociación de seguridad establecida.

La fase 1 de IKE (ISAKMP) negociará el canal seguro entre los nodos, autenticará a su vecino si tiene la clave secreta correcta, y autenticará el nodo remoto a través del canal seguro. La fase 1 de IKE utiliza el “modo principal”, que consta de seis mensajes en tres intercambios de eventos.

El resultado es una asociación de seguridad ISAKMP bidireccional. Los intercambios son de entrada/salida, por lo que cada evento se guarda en la depuración como un evento de entrada desde cada router local hasta el router remoto.

La fase 2 de IKE (IPSec) negociará el tunel IPsec entre los dos nodos finales, autenticará los pares y encriptará el tráfico de datos entre ellos a través del tunel cifrado. La fase 2 de IKE usa el proceso llamado “modo rápido” para llevar a cabo su intercambio para establecer dos asociaciones de seguridad unidireccionales.

A continuación en R1 habilitaremos dos comandos de depuración: “debug crypto isakmp” y “debug crypto ipsec”.

R1#debug crypto isakmp
*Crypto ISAKMP debugging is on
R1#debug crypto ipsec
*Crypto IPSEC debugging is on

Ahora enviaremos un ping extendido desde la dirección de loopback de R1 hasta la dirección de loopback de R3 y veremos la depuración de la salida de ambos routers. Veremos tanto la negociación ISAKMP como el establecimiento de la asociación de seguridad IPsec.

R1# ping
Protocol [ip]:
Target IP address: 172.16.3.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, String, Record, Timestamp, Verbose [none]:
Sweep range of sizes [n]:

En medio de una salida bastante extensa, el resultado obtenido ha sido el siguiente.

*Type escape sequence to abort.
*Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
*Packet sent with a source address of 172.16.1.1
..!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 228/273/296 ms

Ya podemos cancelar la instrucción de depuración.

R1#undebug all
All possible debugging has been turned off

Y ahora sí que se pueden ver datos al introducir los comandos de cifrado.

Podemos observar que esta vez sí que se han encriptado paquetes, y que se han formado varias asociaciones de seguridad.

14. CONFIGURACIONES FINALES

Las configuraciones finales se pueden observar a continuación mediante el uso de la instrucción “show running-config”.

____________________________________________________________________
R1#show running-config
Building configuration...
Current configuration : 2114 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 5
lifetime 3600
crypto isakmp key sssi address 192.168.23.3
!
crypto ipsec security-association lifetime seconds 1800
!
crypto ipsec transform-set 50 esp-aes 256 esp-sha-hmac
!
crypto map MAPA1 10 ipsec-isakmp
set peer 192.168.23.3
set security-association lifetime seconds 900
set transform-set 50
set pfs group5
match address 101
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
crypto map MAPA1
!
!
router eigrp 1
network 172.16.0.0
network 192.168.12.0
no auto-summary
!
ip classless
no ip http server
no ip http secure-server
!
logging alarm informational
access-list 101 permit ip 172.16.1.0 0.0.0.255 172.16.3.0 0.0.0.255
!
gatekeeper
shutdown
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
____________________________________________________________________
R2#sh run
Building configuration...
Current configuration : 1589 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.23.2 255.255.255.0
serial restart-delay 0
clock rate 64000
no dce-terminal-timing-enable
!
router eigrp 1
network 192.168.12.0
network 192.168.23.0
no auto-summary
!
ip classless
no ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
shutdown
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
____________________________________________________________________
R3#sh run
Building configuration...
Current configuration : 2024 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 5
lifetime 3600
crypto isakmp key sssi address 192.168.12.1
!
crypto ipsec security-association lifetime seconds 1800
!
crypto ipsec transform-set 50 esp-aes 256 esp-sha-hmac
!
crypto map MAPA1 10 ipsec-isakmp
set peer 192.168.12.1
set security-association lifetime seconds 900
set transform-set 50
set pfs group5
match address 101
!
interface Loopback0
ip address 172.16.3.1 255.255.255.0
!
interface Serial1/0
ip address 192.168.23.3 255.255.255.0
serial restart-delay 0
no dce-terminal-timing-enable
crypto map MAPA1
!
router eigrp 1
network 172.16.0.0
network 192.168.23.0
no auto-summary
!
ip classless
no ip http server
no ip http secure-server
!
logging alarm informational
access-list 101 permit ip 172.16.3.0 0.0.0.255 172.16.1.0 0.0.0.255
!
control-plane
!
gatekeeper
shutdown
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

Comienza la especulación con las direcciones IPv4

Información

No era de extrañar que, con la escasez de direcciones IPv4, su venta comenzara a crecer desmesuradamente pues la especulación está a la orden del día  y aquí no podía ser de otra manera, más cuando las empresas e ISPs siguen demandando estas direcciones, sin importar si ya se han asegurado las IPv6 ya que aún no está terminada toda la infraestructura.
En la zona APNIC, la que ha entrado en fase de agotamiento casi total, las IPS se están cotizando a 4 dólares, en tanto que en la zona ARI han llegado a 3 dólares. La zona RIPE es la que nos corresponde, pero al existir aún algunas direcciones, no se han realizado operaciones de este estilo, aunque tampoco tardarán mucho en llegar.
Ante todo esto, ISOC, el organismo del que depende el registro global IANA, ya ha advertido que no se especule en estos casos, pues son conscientes que muchas empresas tienen IPs que no utilizan y podrían aprovechar la oportunidad para desprenderse de ellas, ante lo que solicita que se sigan las políticas de registro establecidas para no “afectar negativamente el tamaño de enrutamiento de Internet”.
A %d blogueros les gusta esto: